FC2ブログ

VLCのリポジトリ行方不明!?VLC1.1.3 for Ubuntu PPA

UbuntuTweakから追加してたVLCのリポジトリが行方不明になってた?
ちっと調べてみたら最新は1.1.3。俺のとこは1.1.2。
なぜ引っ越したんだぜ?まぁ、開発版だから仕方ないよね><

VLC 1.1.3 is released! PPA for Ubuntu
というわけで。

For Ubuntu 10.04 lucid and ubuntu 10.10 maverick:

Open terminal and type the commands:

sudo add-apt-repository ppa:n-muench/vlc ←ここ、変わっとる!!
sudo apt-get update
sudo apt-get install vlc vlc-plugin-pulse mozilla-plugin-vlc



なので、一回追加してからSynapticからちょっと確認。「リポジトリ」で。
Screenshot-ソフトウェア・ソースこれ、1.1.2までの。ちなみにこれは削除しますた
Screenshot-ソフトウェア・ソース-1これ、1.1.3の方。

この状態でUpdateかけるとVLC関連がきてるので、そのままUpgrade。
Screenshot-VideoLANについてScreenshot-VideoLANについて-1無事1.1.3に。おっけー。

で、変更点は、バグフィックスと拡張機能のUpdate、かな?

What's new in 1.1.3

A bit after the 1.1.2, we had to fix some important crashing bugs and you deserve a new release!

* Taglib crash (CVE-2010-2937 / VideoLAN-SA-1004)
* Fixes for FTP relative paths and directories
* Fixes for Podcast and DVD modules
* ... and many other crashes and errors fixed

* Extensions and scripts updates
* Miscellaneous fixes in interfaces
* Updated translations


ちとこれから実践てすつにかかります。

関連記事
Medibuntuのリポジトリで各種コーデック。DVD再生も。
結局Ubuntuの動画プレイヤーはVLCとSMPlayerがあれば必要にして十分じゃね?
UbuntuTweakを使い倒そう。機能色々
Medibuntuのリポジトリはいずこへ?Ubuntu10.10にコーデック関連色々
総合案内当ブログについて
Windowsの目次Linuxの目次Linuxの目次2・ ・自作PC関連の目次Web技術関連の目次
全記事一覧情報サイト新着RSS一覧

Sponsored Link

Songbird for Linuxが非公式に復活

数カ月前に公式にLinuxのサポート終了、って言ってたSongBird for Linuxがコミュニティで非公式に続いてるようです。
Songbird for Linux: Not extinct yet, deb's for the latest version
今のVer.は1.7.3。
hanks to dedicated community support Linux users can still keep up with the Joneses and benefit from all the latest fixes n' features the player has to offer.
ということで、公式じゃ全然ないけれども。

DLはこちらから↓
http://skyzim.com/songbird-1-7-3-installer/
debパッケージでx32用、x64用とあるので、これをDLしてインストールすればいいだけなのです。
Screenshot_20100819203605.pngばっちしメニューにも追加されて・・・


おや、起動しない・・・


端末から打ってみても・・・

$ songbird

(songbird-bin:15822): GStreamer-WARNING **: Failed to load plugin '/usr/lib64/gstreamer-0.10/libgstdvdspu.so': /usr/lib64/gstreamer-0.10/libgstdvdspu.so: undefined symbol: gst_video_event_parse_still_frame
././songbird-bin: symbol lookup error: /usr/lib/python2.6/dist-packages/gst-0.10/gst/_gst.so: undefined symbol: gst_xml_get_type
Could not initialize GStreamer: Error re-scanning registry , child terminated by signal


お?GSTreamerのエラー??
というわけでうちの環境(Lucidx64)ではなぜか起動しません><
VAAPIので何かいじったのかな?
しかしなんか動画対応もしてるけどバグは多いとの噂も。
非公式だし、仕方ないよね><

関連記事
SongBird入れてみたけど、Getdebの仕様が変わってる?
総合案内当ブログについて
Windowsの目次Linuxの目次Linuxの目次2・ ・自作PC関連の目次Web技術関連の目次
全記事一覧情報サイト新着RSS一覧

Sponsored Link

xvbaのupdateでATI環境での動画再生支援がかなりまともに効くようになったのか?

A New Release Of The AMD XvBA Back-End To VA-API

This update to the xvba-video package, which is version 0.7.1 while the initial 0.7 release also came in the past 24 hours too, adds compatibility with some different VA-API versions, fixes rendering of GL_RGBA textures, fixes subpicture rendering of certain sizes, requires the fglrx 8.69.2 driver or newer, and various other fixes.


ちゅーわけで、過去何度か格闘してましたATIのUbuntu上での動画再生支援。
またもやUbuntuで動画再生支援(ATI)
じゃあVLC on LucidでVAAPIとかってどうよ?

ここで使ってたxvbaがUpdateされてますので、早速入れなおしてみましたよ。
xvba自体のDLはこちらから。http://www.splitted-desktop.com/~gbeauchesne/xvba-video/
今回の新Ver.は0.7.1-1。
これ、結構変わりました。すごいいい感じ。

環境は5670、Catalyst10.7。
まぁ、テスト動画は以前から使ってるので、VLCがリポジトリから入るのでVA-API対応してくれたので、VLCで。Ver.は1.1。出力設定はXV。
Screenshot_20100710072612.pngBig_Buck_Bunny。
これは以前から負荷は低めだったけど、それでもここまで安定して低負荷ってのはなかったように思います。

高精細コンテンツ ショーケースから落としたのもいくつか。
Screenshot-1_20100710072611.pngAlexander_Trailer。これは画面切替時によく高負荷になってたけど、これもほぼなだらかに。そして50%超えることはなし。
Screenshot-2_20100710072611.pngDivXThreeScreenExperience。
これ、前から一番重かったんですよね。し・か・し。今回は一部シーンで50%超える程度。フルロードになるシーンは全く在りませんでした。
Screenshot-1_20100614191011.png Screenshot_20100614191012.png
ちなみに前回はこんな感じ。
まぁ、いつものごとくバックで他のアプリ起動した状態でのテキトーなテストだし、しかも前回VLCでやったときはクロック可変のままやってたんだよねww
ので、まぁほんとに参考程度に。

さて、導入手順は前にもやってるけど、fglrx、libva、xvbaを入れればOK。
http://www.splitted-desktop.com/~gbeauchesne/libva/pkgs/から。
俺の場合はamd64からlibva_0.31.0-1+sds13_amd64.deb libva-dev_0.31.0-1+sds13_amd64.debをDLしてインストール。
(この前に$ sudo apt-get install devscripts
$ sudo apt-get install cdbs debhelper autotools-dev libdrm-dev x11proto-xext-dev libxext-dev libxfixes-dev libgl1-mesa-dev automake1.9 libtoolはやったような・・・)

で、xvba。
http://www.splitted-desktop.com/~gbeauchesne/xvba-video/から。
xvba-video_0.6.11-1_amd64.debをDLしてインストール。

で、VLCの場合は
https://launchpad.net/~c-korn/+archive/vlc
ここのリポジトリ追加して最新Ver.1.1.0に変えればおっけー。

Mplayerはビルドが必要ですね。
http://www.splitted-desktop.com/~gbeauchesne/mplayer-vaapi/からmplayer-vaapi-latest-FULL.tar.bz2をDLして/homeに展開。
$ sudo apt-get build-dep mplayer
$ cd mplayer-vaapi-20100414
$ ./checkout-patch-build.sh
実はここで
$ ./checkout-patch-build.sh

Running VA API enabled MPlayer
------------------------------

$ cd mplayer-vaapi
$ ./mplayer -vo vaapi -va vaapi

can be a pathname or an URL.

For OpenGL rendering:
$ ./mplayer -vo vaapi:gl -va vaapi

For OpenGL rendering with reflection effect:
$ ./mplayer -vo vaapi:gl:reflect -va vaapi


で、URLのところに再生したいファイルへのパスを入れればおk。
mp4でエラー出る時は
>しかし、実は -vo vaapi だけを指定し -va vaapi を指定しなければmp4を正常に再生できます。
とのことです。

現状VLCが一番お手軽かなー。導入も、扱いも。
ま、まだまだATI環境は発展途中って感じなので、今後に期待ですね。プレイヤーの導入が簡単になればね。いいんだけどね。

関連記事
またもやUbuntuで動画再生支援(ATI)
じゃあVLC on LucidでVAAPIとかってどうよ?
せっかくなのでFullHD動画再生テスト
Ubuntuの動画再生支援について
Marverickにきたfglrxの性能やいかに
総合案内当ブログについて
Windowsの目次Linuxの目次Linuxの目次2・ ・自作PC関連の目次Web技術関連の目次
全記事一覧情報サイト新着RSS一覧

Sponsored Link

ブログ内検索

カスタム検索

フリーエリア

クリックで救える命がある。

レンタルサーバー

さくらのマネージドサーバ
さくらインターネットのVPS
ConoHaのVPS
WebARENA VPSクラウド
99円レンタルサーバー
【CloudCore VPS】
GMOクラウドのレンタルサーバー
転送量無制限 ABLENET
@WAPPYレンタルサーバー
SPPDレンタルサーバー

カテゴリー+月別アーカイブ

 

アクセスカウンター

現在の閲覧者数:

プロフィール

tmin

Author:tmin
PCヲタ。ライト2ちゃんねら。
スロット好きのギャンブラー。(元
むしろ人生がギャンブルだが目下のところ負けっぱなし。
座右の銘は「結果オーライ」。故に基本適当。
トラブルもまた楽しみのひとつ

コメント、トラバ、相互リンク歓迎。お気軽にどうぞ。
当ブログについて
Twitterでこっちとあっちの更新情報流すことにしてみます。
http://twitter.com/t_min
Project Mikunchu♪Wikiできました。
Mikunchu200x40.png