スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
総合案内当ブログについて
Windowsの目次Linuxの目次Linuxの目次2・ ・自作PC関連の目次Web技術関連の目次
全記事一覧情報サイト新着RSS一覧

Sponsored Link

メイン機にもLMDE

今日、メイン機の方にもLinux Mintというか、LMDE(201403)を入れてみた。
動機はですね、Mikutterが使いたかったから!!」
はい。Debianでも使えていたんですが、DebianはメジャーアップデートでGUI環境が変わったのになーんか馴染めなかったんですよ。KDE使ったりもしてたのですが。んでさらにちょっと前、(GSTreamer系のUpdateで?)音楽や動画がことごとく再生できなかったりもして、なんとなーく遠ざかっちゃってたんですけどね。

Dell Studio 1737にLMDEと日本語環境とでサブ機に入れたのが思いの外良かったものですから。
というわけで入れてみましたが色々とハマったとこもあったので自己メモ兼ねて。

まず、/homeを残したまま/だけ入れ替えっていう形で入れたので、そのせいで招いたトラブルもいくつか。
選んだのはLMDE201403 x64 Cinamon
ハードは970BE、M4A,DDR3 1333 1Gx4、Radeon HD5670という、数年前のままの構成。

まぁ、インストール自体は簡単ですね。前回と同じくUnetbootin使ってLiveUSB作って(LinuxでもUnetBootinあります)、一応最初はミスるの怖かったのでインストール先のHDD以外の2つ外してw(MBR関係は慣れないと怖いです

日本語環境
上のLinux Mint のダウンロードのところに日本語環境インストールの方法が書いてあるのでまずはそのとおりに。
$ wget -q http://packages.linuxmint-jp.net/linuxmint-ja-archive-keyring.gpg -O- | sudo apt-key add -
$ sudo wget http://packages.linuxmint-jp.net/sources.list.d/linuxmint-ja.list -O /etc/apt/sources.list.d/linuxmint-ja.list
$ sudo apt-get update
$ sudo apt-get dist-upgrade
LMDE の場合
$ sudo apt-get install mint-lmde-ja --install-recommends

前回記憶があやふやでしたが、ここでibus-mozc入ってました。あとFirefox-jaとかThunderbirdとか。

最凶のTwitterクライアント、Mikutterのインストール。
$ sudo apt-get install mikutter
で入るんだけど、予想通りというかなんというか、これは起動してくれなかったのでgitでもらってきます。
$ sudo apt-get install git
$ git clone git://toshia.dip.jp/mikutter.git
$ cd mikutter/
$ ./mikutter.rb
はい。無事起動しました。

ここで1つ目の問題発生!!ログインしなおしても日本語入力ができません/(^o^)\
前回学んだので、自動起動にibus-daemon追加したりしてたんですけど。しかも右下にちゃんとMozcのアイコン出てるんですけど!!
ってTwitterで日本語書けないので、つたない英語やらローマ字ママの日本語でちょこちょこつぶやいてたら、数人が助けに来てくれた。
ibusがダメ、とか、環境変数変えれば大抵直る、とか。
結果として、環境変数変更で解決した。
Ubuntuの英語環境をCUIにて日本語対応にする
というか、「Mikutterで日本語入力ができなくて」なんてことをちょっとつぶやいただけで色んなとこからアドバイスやら助けが飛んでくる俺のTL素敵すぎる!みなさんありがとー。

しかし調子に乗った俺はここで大きなことをやらかしてしまう。
そう、Linuxにおける鬼門の一つ、fglrx。これ入れたら、画面がかなりおかしな事になった。Windowsのセーフモードみたいなあれ。
しかしこんなのはいつもの事だったはず、と調子こいてた俺は
# aticonfig --initial -f
を打つ。
致命的だった。GUI画面が立ち上がらなくなり、しかたなくリカバリーモードで# apt-get purge fglrxとか打つ。
「X.org設定ファイルがなくなるけどいいの?」みたいな警告が出てたけど、どうせ作りなおされるだろう、最悪またリカバリーモードから、と思って再起動。
とどめを刺した
リカバリーモードですら、画面が見えなくなった。
察するに、内部的には立ち上がっているのだが。

ここで再インストール。
どうせx64のつもりで実はx32を入れてたからいいといえばいいのだが。

せっかくなので、たぶんUbuntu使ってた頃から使いまわした/homeからFirefoxとjdと、あといくつかの設定ファイルやら取り出して完全にクリーンインストールしてみた。

さっきと同じ手順だったはずなのに、Mikutter起動、日本語入力、全てがサクサク。
Mintは(グレーな国ができてしまうのかもしれないが)最初から音楽も動画も再生できるし。

Firefoxはいくつかの設定吹っ飛んでたので、いつものごとくFEBE使って直近のバックアップから復元。
fglrxは怖くてまだ入れてないw

970BEを定電圧化しようと、PHCとK10railgunを試してみた。
AMD K8 patches:PHCは# dkms_installでエラーはいて、再起動してみたけど
$ cat /sys/devices/system/cpu/cpu0/cpufreq/phc_controls
cat: /sys/devices/system/cpu/cpu0/cpufreq/phc_controls: No such file or directory
ダメでござる。

k10railgunによるK10/K10.5世代のAMD製CPUの電圧下げに関するメモ(バージョン0.801.8a時点・ページ2/3)
K10railgunしかない。
k10railgun 0.801.8a
古いので大丈夫かなとおもいながら。
$ cd k10railgun/
# modprobe msr
# ./k10railgun.py
---- CPU/System Information --------------------------------------------------
M/B(BIOS) / BaseClk :M4A87TD/USB3(2001 ) / 200.00MHz
CPU Name / Cores/S :AMD Phenom(tm) II X4 970 Processor / 4Cores/Socket
CPUID _ExFM_BaseFM-S:00100F43 Revision BR-C3
Flags :HwC1EEi/SmiC1EDi//C5Di/AVimp/SVI/DP/BE
---- Freq./Pstate Management --------- ---- Power Management ----------------
MaxFreq./Pstates:7900MHz/ 3 VDD Renge mV :max 1550-min 0
CPB Src/Count :Di/0 PSI_L :En / 1125mV>=VDD ON
VSSlamTime/P0-Pm:200us/tns / 500mV AltVid vss :Di 0us
AltVid Start/VDD: 900mV / 900mV
[Default]F4x1[F3:E0] Register |[CurrentB]MSRC00100[68:64] Register
Freq Ratio FIDh VDD VIDh Nb NbVh | Freq Ratio FIDh VDD VIDh Nb NbVh
PS MHz /DID mV /IddA VDD /DID | MHz /DID mV /IddA VDD /DID
0: 800 4.00 00/1 900 34/40 1050 28/0 | 3500 17.50 13/0 1300 14/84 1100 24/0
1: 2800 14.00 0c/0 1200 1c/60 1050 28/0 | 2800 14.00 0c/0 1200 1c/60 1100 24/0
2: 2200 11.00 06/0 1125 22/44 1050 28/0 | 2200 11.00 06/0 1125 22/44 1100 24/0
3: 800 4.00 00/1 900 34/16 1050 28/0 | 800 4.00 00/1 900 34/16 1100 24/0
CPU0 CPU1 CPU2 CPU3
[CoFreq MHz] 2200 800 800 800
[CoVDD mV ] 1125 1125 1125 1125

Debianの時に使ってたはずだったんだけど、このブログで書いてないので設定をすっかり忘れてしまっている。やばい。
結局ちょと探りながらこのあたりに・・・

# ./k10railgun.py --fq=3500,2500,1600,800 --vdd=1275,1150,980,800 -w
---- CPU/System Information --------------------------------------------------
M/B(BIOS) / BaseClk :M4A87TD/USB3(2001 ) / 200.00MHz
CPU Name / Cores/S :AMD Phenom(tm) II X4 970 Processor / 4Cores/Socket
CPUID _ExFM_BaseFM-S:00100F43 Revision BR-C3
Flags :HwC1EEi/SmiC1EDi//C5Di/AVimp/SVI/DP/BE
[VDD] changed.
[DID/FID] changed.
[MSR] Pstate Registar Change.
[MSR] Write Default P0 -> Current P0((BE TRICK step 1/2)
[KernelModule] Reload Powenow-k8
[MSR] Pstate Registar Change.(TRICK step 2/2)
---- Freq./Pstate Management --------- ---- Power Management ----------------
MaxFreq./Pstates:7900MHz/ 3 VDD Renge mV :max 1550-min 0
CPB Src/Count :Di/0 PSI_L :En / 1125mV>=VDD ON
VSSlamTime/P0-Pm:200us/tns / 500mV AltVid vss :Di 0us
AltVid Start/VDD: 900mV / 900mV
[CurrentB]MSRC00100[68:64] Register |[CurrentA]MSRC00100[68:64] After
Freq Ratio FIDh VDD VIDh Nb NbVh | Freq Ratio FIDh VDD VIDh Nb NbVh
PS MHz /DID mV /IddA VDD /DID | MHz /DID mV /IddA VDD /DID
0: 3500 17.50 13/0 1300 14/84 1100 24/0 | 2800 14.00 0c/0 1200 1c/84 1100 24/0
1: 2800 14.00 0c/0 1200 1c/60 1100 24/0 | 2500 12.50 09/0 1150 20/60 1100 24/0
2: 2200 11.00 06/0 1125 22/44 1100 24/0 | 1600 8.00 00/0 975 2e/44 1100 24/0
3: 800 4.00 00/1 900 34/16 1100 24/0 | 800 4.00 00/1 800 3c/16 1100 24/0
CPU0 CPU1 CPU2 CPU3
[CoFreq MHz] 800 800 800 800
[CoVDD mV ] 900 900 900 900
Traceback (most recent call last):
File "./k10railgun.py", line 1341, in
main()
File "./k10railgun.py", line 1338, in main
cli_control(options, argv)
File "./k10railgun.py", line 1143, in cli_control
service().psave(service.autosave_pfile)
File "./k10railgun.py", line 812, in psave
fp.write(service().generate_options())
File "./k10railgun.py", line 799, in generate_options
if ocf :opt+=' --oc'
UnboundLocalError: local variable 'opt' referenced before assignment

え、こっちもダメすか?
と思ったけど、
# sensors
radeon-pci-0500
Adapter: PCI adapter
temp1: +58.0°C

atk0110-acpi-0
Adapter: ACPI interface
Vcore Voltage: +0.79 V (min = +0.80 V, max = +1.60 V)
+3.3V Voltage: +3.31 V (min = +2.97 V, max = +3.63 V)
+5V Voltage: +5.08 V (min = +4.50 V, max = +5.50 V)
+12V Voltage: +12.00 V (min = +10.20 V, max = +13.80 V)
CPU Fan Speed: 444 RPM (min = 600 RPM, max = 7200 RPM)
Chassis Fan Speed: 1486 RPM (min = 600 RPM, max = 7200 RPM)
Power Fan Speed: 0 RPM (min = 600 RPM, max = 7200 RPM)
CPU Temperature: +38.0°C (high = +60.0°C, crit = +95.0°C)
MB Temperature: +39.0°C (high = +45.0°C, crit = +75.0°C)

k10temp-pci-00c3
Adapter: PCI adapter
temp1: +36.5°C (high = +70.0°C)
(crit = +90.0°C, hyst = +88.0°C)

どうもちゃんと下がっているよう。

せっかくなのでConkyでモニタリングしながら・・・とか思ったら、さっき/homeを消した時に.conkyrc取り出してなかったの思い出した。やばい。
したら、えらく昔にメモってた。
ConkyconkyCONKY ~インストールから設定まで~
しっかしこの頃、Athlon64x2とか使ってたんだよなぁ、とか思いつつ、なんとか一部書き換えて完了。
4コアなので、CPUのところを増やしたり、何故かこの時/bootなんてモニタリングしてるから、ここ/homeに変えたり。
んでも4コアの2コア目までしか温度とか電圧拾ってくれないんだよねー。

てことで
# sensors
radeon-pci-0500
Adapter: PCI adapter
temp1: +58.0°C

atk0110-acpi-0
Adapter: ACPI interface
Vcore Voltage: +0.79 V (min = +0.80 V, max = +1.60 V)
+3.3V Voltage: +3.31 V (min = +2.97 V, max = +3.63 V)
+5V Voltage: +5.08 V (min = +4.50 V, max = +5.50 V)
+12V Voltage: +12.00 V (min = +10.20 V, max = +13.80 V)
CPU Fan Speed: 444 RPM (min = 600 RPM, max = 7200 RPM)
Chassis Fan Speed: 1486 RPM (min = 600 RPM, max = 7200 RPM)
Power Fan Speed: 0 RPM (min = 600 RPM, max = 7200 RPM)
CPU Temperature: +38.0°C (high = +60.0°C, crit = +95.0°C)
MB Temperature: +39.0°C (high = +45.0°C, crit = +75.0°C)

k10temp-pci-00c3
Adapter: PCI adapter
temp1: +36.5°C (high = +70.0°C)
(crit = +90.0°C, hyst = +88.0°C)

# sensors-detect
昔と違って、コピペで貼ったら大変なことになりそうな数の質問があったけど全部y
# sensors
radeon-pci-0500
Adapter: PCI adapter
temp1: +58.0°C

atk0110-acpi-0
Adapter: ACPI interface
Vcore Voltage: +0.79 V (min = +0.80 V, max = +1.60 V)
+3.3V Voltage: +3.31 V (min = +2.97 V, max = +3.63 V)
+5V Voltage: +5.08 V (min = +4.50 V, max = +5.50 V)
+12V Voltage: +12.00 V (min = +10.20 V, max = +13.80 V)
CPU Fan Speed: 445 RPM (min = 600 RPM, max = 7200 RPM)
Chassis Fan Speed: 1490 RPM (min = 600 RPM, max = 7200 RPM)
Power Fan Speed: 0 RPM (min = 600 RPM, max = 7200 RPM)
CPU Temperature: +38.0°C (high = +60.0°C, crit = +95.0°C)
MB Temperature: +40.0°C (high = +45.0°C, crit = +75.0°C)

k10temp-pci-00c3
Adapter: PCI adapter
temp1: +36.6°C (high = +70.0°C)
(crit = +90.0°C, hyst = +88.0°C)
変わりませんでしたすみません。

なんだかんだあったけど、久しぶりにインストール〜セットアップってのをそこそこ楽しみながら出来た気がする。

えーっと、これからLinux入ってくる人にLMDEは割とおすすめ。通常版だと半年ごとにクリーンインストールだったりするし、Debianだとパッケージが古くなっちゃったりするし。
その点セミローリングリリースなLMDEは一回インストールしたら(上で俺がやったfglrxのように)壊さない限りそのままで使えるし。
次いでDebianもしくはLTS(ロングサポート版、2年毎、5年までサポートあり)かなーと。

俺みたいなインスコ厨でもない限り、半年ごとにクリーンインストールってのはやっぱ結構ハードル高いと思うよ。
まぁ、その半年立つ頃には依存関係ぐちゃぐちゃになっててクリーンインストールしたほうがいいって状態になるような使い方もあるから一概には言えないけど。
あと、/home分けとくのはおすすめ。でも俺みたいにデストリ変えてるのに/home保持とかわけわかんない使い方はしないほうがいいと思います。

あと、Linuxはメーカーさんからのドライバがあったりなかったり、あっても不安定だったりするからそのへんは注意。

いい加減fglrxは安定しろ!

・関連記事
Dell Studio 1737にLMDEと日本語環境と
LMDEセットアップいろいろ
Mozcに辞書追加 on LMDE201403
LMDEにfglrx(リベンジ
mintToolsとはこれいかに
Cinnamon or MATE, or other Desktop?
k10ctlを使ってLinux上でPhenomⅡの低電圧化を試みる
Linux PHC使ってDell Studio 1737の低電圧化(LMDE)
LMDE2014からLMDE2(Besty)にupgrade
関連記事
総合案内当ブログについて
Windowsの目次Linuxの目次Linuxの目次2・ ・自作PC関連の目次Web技術関連の目次
全記事一覧情報サイト新着RSS一覧

Sponsored Link

コメントの投稿

管理者にだけ表示を許可する
ブログ内検索

カスタム検索

フリーエリア

クリックで救える命がある。

レンタルサーバー

さくらのマネージドサーバ
さくらインターネットのVPS
ConoHaのVPS
WebARENA VPSクラウド
99円レンタルサーバー
【CloudCore VPS】
GMOクラウドのレンタルサーバー
転送量無制限 ABLENET
@WAPPYレンタルサーバー
SPPDレンタルサーバー

カテゴリー+月別アーカイブ

 

アクセスカウンター

現在の閲覧者数:

プロフィール

Author:tmin
PCヲタ。ライト2ちゃんねら。
スロット好きのギャンブラー。(元
むしろ人生がギャンブルだが目下のところ負けっぱなし。
座右の銘は「結果オーライ」。故に基本適当。
トラブルもまた楽しみのひとつ

コメント、トラバ、相互リンク歓迎。お気軽にどうぞ。
当ブログについて
Twitterでこっちとあっちの更新情報流すことにしてみます。
http://twitter.com/t_min
Project Mikunchu♪Wikiできました。
Mikunchu200x40.png


上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。