スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
総合案内当ブログについて
Windowsの目次Linuxの目次Linuxの目次2・ ・自作PC関連の目次Web技術関連の目次
全記事一覧情報サイト新着RSS一覧

Sponsored Link

ATI Catalyst 10.9 Released

残念!!Ubuntu10.10 marverickには対応してない模様。
これ大丈夫か?正式までになんとかなるのかなぁ?
あぁ、Linux版はこちらから
ATI Catalyst™ Display Driver

で、Windows版はまぁ、いつものごとく4亀が早速レビューしてるのでご参考に
ゲーム周りの最適化や修正が進んだ「ATI Catalyst 10.9」リリース
なんか俺のとこの5670にはあんまり関係なさそうなのばっかなんだけど。

さて、問題のUbuntu10.10 marverickへの対応。
AMD Catalyst 10.9 For Linux Released(Phoronix)

Though as Catalyst 10.9 still isn't ready for Ubuntu 10.10, look for Catalyst 10.10 to be an interesting release.


関心は高いがまだサポートしてないとかなんとか・・・OTL
まぁ、これだけで納得できるわけはないので色々と調べ物
Phoronixの掲示板
AMD catalyst 10.9 has been released

Does it fix the blob problem?
no but ubuntu 10.10 will have mesa7.9 and full r800 support in the radeon driver ;-)

i think this fix the blob problem.


はい、オープンソースドライバを使えと。

Ubuntu本家のフォーラム
xorg-server 1.9 with fglrx
なんかみんな泣いてるんですけど!!
#28

In the process of downloading now. It's not linked to on the site yet (I love that).

I'll report back shortly. Download still has 15 minutes or so, then I'll need to make a package, install, reboot, probably cry.

Oh, I can possibly check the release notes. Hang on.

--edit
No mention of Xorg 7.6 in the release notes, or Ubuntu 10.10. "RHEL 6 Early Look support" but I think that's still on server 1.7. Fedora 13 is 1.8 still so I can't see the enterprise version being newer.

Unfortunately it's starting to look like 10.10 will need 10.10. Hang on...


リリースノート見ないで凸ってハングしたらしい。。。
#32

After trying a variety of things I ended up compiling and installing xorg-server-1.8.2 from source in order to downgrade from Maverick's 1.9 server, then installed the latest 10.9 catalyst drivers. I'm running kernel 2.6.35-21 right now, and Xorg -version shows server version 1.8.2, but I'm still getting the "undefined symbol" error whenever I attempt to start X using fglrx drivers. Any thoughts? 1.8.2 is running fine under the open-source drivers, but maybe I need to downgrade other packages as well?


色々やった挙句に結局Xorg1.8.2をソースからビルドしてインストールしたけどちゃんとfglrx効いてるのかオープンソースドライバが効いてるだけなのかよくわからんとか。

同じく本家フォーラムfglrx with xserver 1.8 (in progress)

Anybody tried with Catalyst 10.9?


Yes, it doesn't work. Let's hope for fglrx 10.10.

According to some guys from phoronix,
Quote:
there are allready a beta 10.10 with xserver 1.9 support and there is a 10.11 beta.
in 20 days amd will push a 10.10 catalyst into the ubuntu 10.10 repo .


試したけど動かなかったって。

さらに本家フォーラムで紹介されてる力技
Common Problems / Frequently Asked Questions About Testing
#7

I have a solution to a problem with the current Version of Virutalbox. If you tryed to install Ubuntu 10.10 beta in Virtualbox then you probably ran into some trouble installing the guest additions. This is because Ubuntu 10.10 has an unsupported version of Xorg. You need to revert to the lucid version to alleviate the problem.

Here is how I fixed the problem.

Ok I know how to fix the problem... What you need to do is install the old xorg drivers. To do this you will have to open the sources list.

Code:

sudo gedit /etc/apt/sources.list



then put pound symbols infront of the maverick main restricted lines (4 of them)

Ok then open the software sources app and add the lucid main restricted
Code:

deb http://us.archive.ubuntu.com/ubuntu/ lucid main restricted



Ok now reload the packages and make sure that everything is working with apt.

Now go to the synaptic package manager and go to "status" click installed and enter "xorg" into the quick search option then go to xorg-server-core (something like that (second entery after xorg) and mark it for removal (now everything with xorg in its name should be set to be removed) apply and reboot.

Now when you reboot you will see a command line interface. Log-in and type

Code:

sudo apt-get install xorg



now the old xorg drivers from lucid are running! next install the Virtualbox Guest Editions (you may see and error goblygook message) if you see the screen crazy error then wait 3 minutes and hit enter on the keyboard. Then click close on the vm and check send shutdown signal and hit enter. after that you should have access to changing the settings and screen freely!


えーっとですね。これはたぶん、MarverickのXorgのVer.に問題があるから、一時的に(?)Lucidのリポジトリ有効にして、というか追加して、その上でXorgとxorg-server-coreをremove。で、再起動すると(当然のごとく)コマンドライン起動になるので、そこでXorgをインストールして、MarverickのXをLucidのXと入れ替えるっていう。
いいのか?こんなことして・・・

同じく本家
Maverick upgrade breaks Catalyst and X

donot upgrade the x-org and x-server
problems will be solved
use update manager and unmark all related to x-org and x-server
i found this idea in the Chinese Ubuntu Forum
i am not sure whether it works on your system


これは前にも見かけた手法?XorgとXserverのVerを固定した上でUpgrade、という。

さぁ、難しくなってきたぞー。
現状、結局fglrxを使うためにはXは1.8にしとかなきゃいけない。
で、Marverickを入れてから、これのXを(強引に)入れ替える、もしくはLucidから(α3からでもおk?)X関連のパッケージ固定してUpgrade。結局X1.8にしなきゃいけないっぽい。
しかし、言ってもまだβ。開発版です。
ここまでして入れることか?
いや、まぁ、9.04以降、βでは既に実機に入れてるのを貫いてきた俺が言うのもなんだけど。
まだβだし、大量のバグフィックスされてる段階だし、極力デフォルトで行ったほうがいいと思うんですよね。バグ報告、バグフィックスの面から言っても、使い勝手や安全性から言っても。
ま、でもこういう力技を試して楽しむのもまた一興ではあるんですけどね。

うーむ。5670、すなわちEverGreenシリーズ使ってる身から行っても、プロプラ待ちたいんですよねー。OSSドライバはCompizまともに効かなかったりするし、動画再生支援とかいまいち試せないし。
まぁ、視覚効果だけならばKDEでKwinなら(たぶん)使えるので、コレで行ってもいいんだけど。

というわけで、せっかくリリースになった10.9ですが、見事に悪い予感が的中した感じ。
ま、でも正式版までにはそれなりになんとかしてくるとは思うんですが。

あぁ、ちなみにNVIDIAは多少問題あるけど大体大丈夫な感じみたい。
Nvidia graphics laggy in Maverick? Try this(OMG!Ubuntu!)
フォントの設定で回避するのが第一策
最新のドライバ(?)260.19.06 driver を入れるのが第二策、らしいです。

うーむ。やはりLinux環境ではGeforceの方がいつも安定してるような感じですねー。
ま、トラブルと戦うのもまた楽しみの一つ、ではあるんだけど、ココまで続くとなぁw

またなんか動きがあって、見つけれたら記事にするつもり。たぶんこれからちょっと慌ただしくなるんじゃないかな?ATIの方は。

関連記事
Ubuntu 10.10 MaverickMeerkat βのレビューが上がってますね
Ubuntu 10.10 MaverickMeerkat βReleased!
Ubuntu10.10 β 実機に入れるのははもう少し待ったほうがよさそうよ。
MarverickのXorgのVer.にATIドライバは対応してないとか何とか
Catalyst10.7 Released!!
ATI Catalyst 10.8 Released (for Linux)
fglrxがMarverickに対応する兆し?
関連記事
総合案内当ブログについて
Windowsの目次Linuxの目次Linuxの目次2・ ・自作PC関連の目次Web技術関連の目次
全記事一覧情報サイト新着RSS一覧

Sponsored Link

768:No title
まあ、ATI(AMD)に関してはプロプライエタリドライバはNVIDIAより地雷率は高いですけどね。
逆に数世代前(R600とか)や枯れきった(R300付近)ものであれば3Dも含めてオープンソースドライバはかなり安定して動作しますよ。(NVIDIAがnouveauでようやく限定的に3Dサポートを初めたのに対して)
770:No title
そう。8.10、10.04のβ時と、ちと地雷を踏んだ経験が・・・

オープンソースドライバもそこまでいってるんですね。一旦3650に戻すのもありかなぁ?(うるさいけどw
今使ってるのが5670なので、なかなかオープンソースではストレスたまっちゃう場面が多いんですよねー。

プロプラではNVIDIA、オープンソースで枯れた世代ならばATIって感じでしょうか?
うーむ。次に買うときは新めのに行くならNVIDIAも考えようかなぁ。いや、でもその頃には今のカードが枯れたものになってるかな?
悩ましいですw
771:No title
少し脱線するんですけど、UbuntuでFirefox使ってて、ページ拡大すると画像が粗くなるのは普通ですか?
スムージング的な機能が効いていないのかな?
ドライバ当てても変わり無いし、うちだけ?ATIだから?Ubuntuだから?
772:No title
画像はあまり感じないですねー。
10.04の初期で、フォントのヒンティングがかかってなかったときはあったんですけど、このときは↓で直りました
>140 名前:139 [sage]: 2010/05/04(火) 04:40:45 ID:vJdnG2iV (4)
>・FirefoxでUIフォントにヒンティングが掛かっていて汚い

sudo rm /etc/fonts/conf.d/10-hinting-slight.conf
sudo ln -s /etc/fonts/conf.avail/10-unhinted.conf /etc/fonts/conf.d/.
sudo dpkg-reconfigure fontconfig

気になる人はこれで治るけどあくまで自己責任で…

でも、画像では関係ないかなぁ・・・
773:No title
文字の小さいページで拡大すると、フォントは問題ないんですけど画像が110%から直ぐにシャギーが目立つんですよね。
今、Opera試してみてるけど、問題ないみたいです。
9.04から使い始めて、おかしいなと思いつつFirefoxのVerUpでも変化無しなのでUbuntuでの仕様かと諦め気分でした。うちの問題なのかなぁ?
775:No title
うーん。うちではそういった現象はきにならないですねー。
Operaで大丈夫ということはもしかしてFirefoxの設定かも?
特に/home残してUpし続けているなら、もしかしたらはるか昔のなんらかの設定が残ってて悪さしているとか、でしょうかね?
778:No title
う~ん、/home分けてないですし、verごとにクリーンインストールしてるんで、環境的な問題なんですかね?
僅かに期待して4beta6を試してみたけど、変わり無しでした。
Opera、Win版と違ってフォント綺麗なんで、使ってみようかなと。
781:No title
ふむ。どうも環境の問題のような気もしますが、設定ファイルの可能性も棄てきれないって言うビミョーなところかと。
もし気になるようでしたら、~./mozzilaをバックアップした上で削除or移動しちゃって、Firefox再インストールとかすればまっ更なデフォルト状態になるかな?(/usr/shareにもなんかあったような気が・・・

そういやOpera新しくなったんでしたっけ?ちょっと試してみようかな?
803:No title
どうもです。
Ubuntu+Firefoxで調べてて、訪れたBlogの方がHD4870環境だったので、拡大時の件聞いてみたら色々と確認してくれまして、9.10、10.04、10.10上でNGみたいです。これ4xxx系の問題ですかねぇ。
でもこれでグラボ換えれば問題解決出来そうですね。NVIDIAは大丈夫かなぁ?
804:No title
おや、4xxx系ですかねー?うちでは3650→今回の5670と使ってますが、ちょっと現象確認とれず、ですね。3650の最後の方はまだ9.10だったと思いますが、思い当たるところがないです。
AMDのグラボはどうもLinux上ではなかなかドライバ的に安定してくれないですねー。何か機能が変わるとついていけてなかったりとか。
今のところNVIDIAのほうがいろんな場面で無難といえば無難な感じがしますねー。KMSのときもなんだかんだで問題出てる人のほうが少ないような感じでしたし。

あまりお力になれなくて申し訳ないです。ハード系の情報まとめてあるところとかあると便利なんだけどなー。。。
805:No title
いえいえ、こちらこそ本当に助かってます。ありがとうございます。

さてこれで安全確実な5xxx系で行くか、6xxx系にするか、WinでBoostの効きがいいみたいなNVIDIAにするか、どうしようかな~。
809:No title
どうもです。
拡大問題の件ですが、
Ubuntu TweakのソースセンターでFirefox Daily Buildsを追加して、Firefox 4.0
Firefox 4.0 core
Firefox 4.0 branding
xulrunner 2.0
をインストールして試してみたところ、あらっ?問題解決しています。
Minefield 4.0 b8 pre 英語版です。

最初ちょっと目を疑いましたけど、全く問題無く、今まで長い間何だったのって感じです。
結局、Firefoxの問題だったんでしょうか? これで標準のFirefoxも4.0になれば大丈夫ですかね。
812:No title
おや。これは意外な。
今のところはMinefieldになってるんですかね。一時期使ってましたが、一部メニューの日本語表示以外、特に不便はなかったかな?
あ、アドオンの対応が・・・
確か今秋正式でしたね。4.0。
またリポジトリに上がるのはちょっと遅れるかもしれないけど、最近の感じだと数週間以内には上がってきそうですから、これで解決だといいですねー。

コメントの投稿

管理者にだけ表示を許可する
ブログ内検索

カスタム検索

フリーエリア

クリックで救える命がある。

レンタルサーバー

さくらのマネージドサーバ
さくらインターネットのVPS
ConoHaのVPS
WebARENA VPSクラウド
99円レンタルサーバー
【CloudCore VPS】
GMOクラウドのレンタルサーバー
転送量無制限 ABLENET
@WAPPYレンタルサーバー
SPPDレンタルサーバー

カテゴリー+月別アーカイブ

 

アクセスカウンター

現在の閲覧者数:

プロフィール

Author:tmin
PCヲタ。ライト2ちゃんねら。
スロット好きのギャンブラー。(元
むしろ人生がギャンブルだが目下のところ負けっぱなし。
座右の銘は「結果オーライ」。故に基本適当。
トラブルもまた楽しみのひとつ

コメント、トラバ、相互リンク歓迎。お気軽にどうぞ。
当ブログについて
Twitterでこっちとあっちの更新情報流すことにしてみます。
http://twitter.com/t_min
Project Mikunchu♪Wikiできました。
Mikunchu200x40.png


上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。